Elmo Cameras Unresponsive

Issue

A classroom Elmo camera has become unresponsive and is not outputting video.

 

Environment

  • Elmo cameras

 

Information

This issue occurs when Elmo cameras are left on (power button is blue) for extensive periods of time. The cameras may have been unintentionally left turned on by previous users. Unfortunately, there is not a permanent fix for the issue as per Elmo's knowledge base: TT-12W, MA-1, MO-2 performance issues (Elmo Support) 

 

Resolution

In order to restore an Elmo camera experiencing this issue to a responsive state, the power cable must be unplugged and plugged back in, then the camera must be power cycled. To avoid the issue entirely, ensure all users of Elmo cameras power off the devices when done using them.

 

Cause

Leaving Elmo cameras turned on when done using them.