I can't launch Respondus Lockdown Browser

Issue

Students receive one or more error messages when launching Respondus Lockdown Browser when using a Grand Rapids Community College (GRCC) student loaner laptop.

  • Error messages may indicate that the application has been "illicitly modified."

 

Environment

  • Microsoft Windows Build 21H2 or newer

 

Information

Students may manually install and trust the Respondus certificate using the below instructions. Alternatively, newer student loaners will receive these certificate as part of the device provisioning and preparation.

Resolution

  1. Download Respondus Lockdown Browser
  2. Locate the downloaded installer
    1. By default it will be located in your Downloads folder
  3. Right-Click the file
  4. Select Properties
  5. Click the Digital Signatures tab
  6. Select Respondus, Inc. in the Signature List
  7. Click Details
  8. Click View Certificate button
  9. Click Install Certificate... button
  10. Select Local Machine
  11. Click Next 
  12. Click Yes button to allow the Windows Host Process to make changes to your computer
  13. Select Automatically select the certificate store based on the type of certificate
  14. Click Next button
  15. Click Finish
  16. Click OK button to close the Certificate Import Wizard confirmation dialog box
  17. Click OK to close the Certificate interface
  18. Click OK to close the Digital Signature Details interface
  19. Click OK to close the Respondus Lockdown Browser Properties interface
  20. Proceed with Installing Respondus Lockdown Browser.

Cause

The most recent release of Respondus Lockdown Browser (downloaded in July of 2022) was signed by a certificate not intended for code signing. Microsoft Windows does not implicitly trust this certificate. This lack of trust results in Respondus Lockdown Browser throwing the "illicitly modified" error message. 

Details

Article ID: 2369
Created
Wed 7/13/22 1:17 PM
Modified
Wed 2/7/24 7:40 PM