Issue
When launching Respondus LockDown Browser on a GRCC student loaner laptop, students may encounter error messages stating the application has been "illicitly modified" or is untrusted.
Environment
- Microsoft Windows 11 (Build 21H2 or newer)
- GRCC Student Loaner Laptops
Information
This error occurs because the digital certificate used to sign the Respondus software is not automatically trusted by some Windows versions. While newer loaner laptops come with this certificate pre-installed, older models or fresh installations may require you to manually "trust" the certificate before the browser will open.
Note: You must complete these steps before running the installer to ensure Windows allows the application to execute properly.
Resolution
Manually Installing the Respondus Certificate
- Download the Respondus LockDown Browser Installer (opens in a new window).
- Open your Downloads folder and locate the installer file.
- Right-click the installer file and select Properties.
- Click the Digital Signatures tab at the top of the window.
- Select Respondus, Inc. from the Signature list and click the Details button.
- Click View Certificate.
- Click Install Certificate... to open the Import Wizard.
- Select Local Machine as the Store Location and click Next. (Select "Yes" if Windows asks for permission to make changes).
- Choose Automatically select the certificate store based on the type of certificate.
- Click Next, then click Finish.
- You should see a message saying "The import was successful." Click OK on all remaining open windows to close them.
- Double-click the installer file again to proceed with the standard installation.
Cause
The July 2022 release of Respondus LockDown Browser used a specific certificate type that Windows does not implicitly trust for "code signing" (verifying software integrity). By manually installing the certificate to the Local Machine store, you are telling Windows that the software is safe to run, which clears the "illicitly modified" error.