Google Workspace - Internet Explorer Plug In Required

Issue

User is getting a prompt "Plug-in Required" when attempting to access a Google Workspace application.

 

Environment

  • Google Workspace

 

Information

Google Workspace ended support for Internet Explorer on March 15, 2021. Continued use of Google Workspace on IE11 after this date is not recommended due to the increased risk of security vulnerabilities and performance decreases.

Additional information can be found in Google's article.

 

Resolution

Open the application from a supported web browser.

Supported browsers include, but are not limited to:

  • Google Chrome
  • Microsoft Edge (this is Microsoft’s replacement to IE11)
  • Mozilla Firefox
  • Safari

 

Details

Article ID: 1880
Created
Mon 4/5/21 2:19 PM
Modified
Fri 10/1/21 4:56 PM